Engine wont run unless full throttle and wont pass 1200 rpm - Dodge Diesel - Diesel Truck Resource Forums


12 Valve Engine and Drivetrain Talk about the 12V engine and drivetrain here. This is for 1994-1998.5 engine and drivetrain discussion only.

Engine wont run unless full throttle and wont pass 1200 rpm

Reply
 
 
 
Thread Tools Search this Thread
Old 07-09-2018, 07:15 AM   #1  
Registered User
Thread Starter
 
Join Date: Jul 2018
Posts: 3
Engine wont run unless full throttle and wont pass 1200 rpm

Hey guys I'm new to the cummins world I have a 95 12v that is giving me headaches I can only get it to run if i hold the pedel down all the way and then it will only run at about 1200 rpm it sounds great when it's running but as soon as i let off the throttle it dies i have replaced the pre filter,fuel filter,lift pump deleted the fuel heater I took the sending unit out and cleaned the screen blew out the lines and replaced the factory lines with larry b rubber ones I also put in a new overflow valve too I'm out of ideas if anyone has any input I would greatly appreciate it I haven't got to check the fuel pressure yet but I ordered a gauge that's next on my list
Ziggyzag68 is offline   Reply With Quote
Old 07-09-2018, 08:14 AM   #2  
Registered User
 
AlpineRAM's Avatar
 
Join Date: Nov 2001
Location: Austria Europe
Posts: 2,816
Maybe the shutdown solenoid does not lift the lever high enough or the shutdown lever has slipped on the shaft?

Take a look at this thread where a guy had the opposite problem.
AlpineRAM is offline   Reply With Quote
Old 07-09-2018, 08:22 AM   #3  
Registered User
Thread Starter
 
Join Date: Jul 2018
Posts: 3
I read that and removed the fss and have it wired up tight so that's not the issue
Ziggyzag68 is offline   Reply With Quote
Old 07-09-2018, 10:41 AM   #4  
Registered User
 
AlpineRAM's Avatar
 
Join Date: Nov 2001
Location: Austria Europe
Posts: 2,816
OK, then I would check for air bubbles in the fuel- try opening the water drain on the filter with the engine running- route a transparent hose back to the filller neck.
There should be no bubbles.
(I had bubbles from a chafed line in the in-tank module. Drove me mad)

Then a pressure check, or test the overflow valve with a regulated air supply.
(Valve on the bench, apply air pressure until it opens, there should be no leakage and opening should occur at minimum 25 psi, better 31 psi- this is the max flow pressure of the lift pump.)
AlpineRAM is offline   Reply With Quote
Old 07-09-2018, 11:41 AM   #5  
Registered User
Thread Starter
 
Join Date: Jul 2018
Posts: 3
I will give that a try and fully get being drove mad by this I appreciate the input
Ziggyzag68 is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
03 wont run right unless cruize control is set ? Mountaineer 3rd Gen Engine and Drivetrain -> 2003-2007 2 10-04-2011 07:00 PM
wont run unless at 45* timing 97ramctd 12 Valve Engine and Drivetrain 6 10-16-2007 10:50 PM
Engine missing at 1200 -1400 RPM's JVDodge 24 Valve Engine and Drivetrain 28 11-09-2006 01:11 AM
Engine Tap / Tick 1200 rpm's and higher psajb 3rd Gen Engine and Drivetrain -> 2003-2007 7 12-10-2003 03:43 PM
truck doesn't seem to have full power at full throttle? j Performance and Accessories 2nd gen only 12 11-14-2003 09:38 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -5. The time now is 10:10 PM.


Copyright 2017, DieselTruckResource.com
We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.