Are these signs of a bad ECM? - Page 2 - Dodge Diesel - Diesel Truck Resource Forums

24 Valve Engine and Drivetrain Discuss the 24 Valve engine and drivetrain here. No non-drivetrain discussions please. NO HIGH PERFORMANCE DISCUSSION!

Are these signs of a bad ECM?

Reply

 
 
 
Old 12-20-2010, 03:23 PM
  #16  
Registered User
 
Join Date: Oct 2010
Location: Pemberton NJ
Posts: 465
Thanks: 0
Thanked 0 Times in 0 Posts
Assuming you have already checked and cleaned all of the grounds what you can try is to find every major plug in the computer harness and unplug it and plug it back in, a couple of times. This will eliminate any corroded connections. Disconnect both battery grounds before doing this to prevent any spikes. Make SURE the ECM grounds and engine grounds are clean and tight. Doing all of this is free so you have nothing to lose. Check all of the plugs for the PCM also.

Rick
rickf is offline  
Reply With Quote
Old 02-07-2018, 04:00 PM
  #17  
Registered User
 
Join Date: Feb 2018
Posts: 1
Thanks: 0
Thanked 0 Times in 0 Posts
Unhappy Help

i had the same symptoms except mine worked great till hot then had these problems. did u ever find a solution???
Gary Kreiser is offline  
Reply With Quote
 
 
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
DuaneWKKC
24 Valve Engine and Drivetrain
9
01-25-2010 12:16 PM
MJDiesel
1st Gen. Ram - All Topics
9
11-29-2005 04:56 PM
Underpsi
1st Gen. Ram - All Topics
8
11-17-2005 08:32 PM
Flatty
24 Valve Engine and Drivetrain
10
05-04-2005 07:46 PM
TE-44
24 Valve Engine and Drivetrain
19
10-29-2003 04:23 PM


Thread Tools
Search this Thread
Quick Reply: Are these signs of a bad ECM?


Contact Us Archive Advertising Cookie Policy Privacy Statement Terms of Service

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.