24 Valve Engine and Drivetrain Discuss the 24 Valve engine and drivetrain here. No non-drivetrain discussions please. NO HIGH PERFORMANCE DISCUSSION!

Hard Start

Old 10-01-2014, 10:30 AM
  #1  
Registered User
Thread Starter
 
Join Date: Jul 2014
Posts: 4
Likes: 0
Received 0 Likes on 0 Posts
Hard Start

I have a 2002 24 valve 5.9 2500. If it sits for a long period of time it takes a while to crank over. I initially thought it was a bad/weak battery. I tested both batteries and one was bad so I replaced it. The next moring I had the same problem. After checking my starter and alternator I retested the other battery. Altough it was low it passed. I decided to buy another battery just to see if that would fix the problem but it didn't. Now this only happens when the truck sits for a while. If I turn it off and wait 15 minutes it starts right up. I would think if it was the IP it would have trouble cranking over at all times, not just when it sits for a while. Any suggestions?
Djepson is offline  
Old 10-01-2014, 01:35 PM
  #2  
Registered User
 
Join Date: Mar 2007
Posts: 284
Received 9 Likes on 9 Posts
Define "sits for a while"!
nothingbutdarts is offline  
Old 10-01-2014, 01:43 PM
  #3  
Registered User
Thread Starter
 
Join Date: Jul 2014
Posts: 4
Likes: 0
Received 0 Likes on 0 Posts
Around an hour.
Djepson is offline  
Old 10-01-2014, 01:59 PM
  #4  
Registered User
Thread Starter
 
Join Date: Jul 2014
Posts: 4
Likes: 0
Received 0 Likes on 0 Posts
It's been sitting for 3 hours and I went to try and start it but it would not crank. About an hour later I had the idea of bump starting it to see if I could hear the IP runnnig. The IP did run for about 30 seconds so I tried to start it and it roughly cranked over.
Djepson is offline  
Old 10-01-2014, 07:47 PM
  #5  
Registered User
 
Join Date: Mar 2007
Posts: 284
Received 9 Likes on 9 Posts
It still sounds as if you are having starter or battery problems still! If in deed the batteries are good it should have cranked over.
nothingbutdarts is offline  
Old 10-01-2014, 07:57 PM
  #6  
Registered User
Thread Starter
 
Join Date: Jul 2014
Posts: 4
Likes: 0
Received 0 Likes on 0 Posts
After getting home I noticed the smell of diesel. I checked all the injection lines and had one that was a little loose. There was visible signs of a leak but not sure if it was the slightly loose injection line. I am going to let it rest until the morning and see what happens.
Djepson is offline  
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
jacob_armour
3rd Gen Engine and Drivetrain -> 2003-2007
10
02-18-2009 01:44 PM
jckdann7
1st Gen. Ram - All Topics
3
08-31-2008 12:13 PM
T-BoneAK
24 Valve Engine and Drivetrain
0
02-01-2007 02:26 PM
jriggs_18
HELP!
5
01-11-2007 04:43 PM
Erik Dlux
12 Valve Engine and Drivetrain
24
12-08-2004 07:26 AM


Thread Tools
Search this Thread
Quick Reply: Hard Start


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.