3rd Gen Engine and Drivetrain -> 2003-2007 5.9 liter Engine and drivetrain discussion only. PLEASE, NO HIGH PERFORMANCE DISCUSSION!

code p2121 need help

Old 09-07-2014, 10:39 PM
  #1  
Registered User
Thread Starter
 
bigbear4x5's Avatar
 
Join Date: Jan 2008
Location: Petersburg,West Virginia
Posts: 24
Likes: 0
Received 0 Likes on 0 Posts
code p2121 need help

I got code p2121 from what I have read it is the apps sensor. my truck is an 04.5 it does not have the engine mounted apps. where can I buy the apps sensor? I have read where some say it is the same as the one for a hemi but I am not sure. I can not find one for the 04.5 the only one I can find is for the engine mounted apps. thanks
bigbear4x5 is offline  
Old 09-29-2014, 10:00 AM
  #2  
Registered User
 
sdmark's Avatar
 
Join Date: Oct 2006
Location: San Diego California
Posts: 192
Likes: 0
Received 0 Likes on 0 Posts
Apps

I found a couple of dealers online that offer overnight shipping and 1 of them was in Wisconsin. It cost $200 ish with expedited shipping. Google works amazing!!
sdmark is offline  
Old 09-30-2014, 08:06 AM
  #3  
Registered User
 
Join Date: Jul 2004
Location: the mitten
Posts: 506
Likes: 0
Received 0 Likes on 0 Posts
Use the search function for Timbo. He makes an after market apps that is better than OEM for right around $165.

Jim
dezeldog is offline  
Old 09-30-2014, 02:43 PM
  #4  
Registered User
 
TxDiesel007's Avatar
 
Join Date: Dec 2004
Location: Laredo
Posts: 3,411
Likes: 0
Received 0 Likes on 0 Posts
Originally Posted by dezeldog View Post
Use the search function for Timbo. He makes an after market apps that is better than OEM for right around $165.

Jim
sorry to correct you on this one..


pedal mounted APPS, is on the 04.5 and up trucks.. Timbo does the one for the 04 and under commonrail engines...

to the original poster... P2121 is a code I have dealt with.. Do a search and you will find how with the help of my mechanic, I had the issue fixed.. I have an APPS here at the house, but im not certain that it works.. I have not tried it.. Last I checked also, the APPS for these truck was on national back order.. but that was two years ago...

to summarize my posts in short, try the following to save you some time...

batteries, are they good? both been load tested?

number two, a soft reset on the APPS.. instructions are somewhere on this site I do believe..

number three... any other APPS codes? usually a P2122 accompanies it (through my experience)

four, if you clear the codes.. do they come back (try this after a reset)

five. how are all of the grounds? are they good and tight? clean?

six.. how are the connections to the ECM? that has come loose on my truck and caused gremlins galore...

seven.. are the connections clean? lil air sprayer at low pressure is a great asset here..

eight.. on the CR's there is an orange and black wire... that runs down where the AC compressor is on these trucks.. by any chance have you checked that wire? IF so.. does it have a bare spot? if it does that may be causing a short on this..

nine.. are all of your grounds and exposed wires wire loomed? again to avoid the problem of metal to metal contact causing a short...

ten, and finally (for now) have the latest ecm updates been done? any tuning on the truck? take it to stock if so, clear codes with tuner.. soft reset APPS sensor and see what it does..

if the code comes back.. check the above.. and im sorry to say this.. but I promise it will be worth your time.. search my posts on P2122 and P2121..

I had those in conjunction with P0483 and P0480 fan clutch codes..

These darn CRs are wonky.. sometimes some codes affect others... after messing with them for about five years now.. they still never cease to amaze the headaches they can cause..

hope the above helps...

one more thing.. you would be WISE to get the part from a reputable source, or straight from the dealership... yes the hemi one bolts right up, but im not sure on the connections how they correlate from a hemi to a CTD on the sensor... so it would not be an option for me to consider at all... IMHO
TxDiesel007 is offline  
Old 09-30-2014, 09:27 PM
  #5  
Registered User
 
Join Date: Jul 2004
Location: the mitten
Posts: 506
Likes: 0
Received 0 Likes on 0 Posts
TX Diesel007....my bad :-((

Jim
dezeldog is offline  
Old 10-01-2014, 07:23 PM
  #6  
Registered User
 
StealthDiesel's Avatar
 
Join Date: Mar 2007
Location: Calgary, Alberta, Canada
Posts: 1,219
Received 10 Likes on 9 Posts
The APPS on the early common rails is confusing...

For 2003-04.5 trucks, the cable operated APPS can be on the engine or under the driver's side battery. They are not interchangeable.

My manual trans 2004.5 truck has the APPS under the battery.
But many 2004.5 trucks have an engine mounted APPS.
Some say the APPS location is dependant on the type of transmission in the truck but I'm not so sure.

The accelerator pedal mounted APPS/TPS is much simpler and that came out in 2005.
I don't think I've ever seen a 2005 Dodge Cummins with an engine bay mounted APPS.
StealthDiesel is offline  
Old 09-18-2015, 11:56 PM
  #7  
Registered User
Thread Starter
 
bigbear4x5's Avatar
 
Join Date: Jan 2008
Location: Petersburg,West Virginia
Posts: 24
Likes: 0
Received 0 Likes on 0 Posts
i hate to reopen an old thread but i have the p2121 again after new apps install 12 months ago. i have checked all wiring and cleaned grounds but still have and now my pedal drops out which it did not before. not sure what else to check going to try a new apps and see what that does hope all is good. i do not want to price a wiring harness or ecm. if anyone has any ideas please let me know.
bigbear4x5 is offline  
Old 02-15-2016, 12:24 PM
  #8  
Registered User
 
Join Date: Feb 2016
Posts: 1
Likes: 0
Received 0 Likes on 0 Posts
APPS signal voltage at idle

Mine is a 2004.5 Dodge 3500. The Timbo APPS is great, and his website has excellent information. Mine, however had the P2127 code, and the pedal still worked. I had to adjust my APPS by rotating it, and making sure the idle voltage was 0.5 to 0.6 VDC. Mine will not work right if it's above 0.6 vdc or below 0.5 vdc. Above 0.6 = dead pedal !! I didn't have to replace the APPS, just needed to adjust it. PM me for the full story, if you need to.
dennis5150 is offline  
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
ziggy
3rd Gen Engine and Drivetrain -> 2003-2007
1
06-24-2013 05:57 PM
PHX_ATC
3rd Gen Engine and Drivetrain -> 2003-2007
10
01-22-2010 01:11 AM
Diesel Rig
3rd Gen Engine and Drivetrain -> 2003-2007
1
09-15-2009 12:29 PM
Hoss
HELP!
7
04-19-2006 01:28 PM
katoiler
3rd Gen Engine and Drivetrain -> 2003-2007
3
04-28-2004 03:05 AM


Thread Tools
Search this Thread
Quick Reply: code p2121 need help


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.