Couple new noises after front u-joints and clutch install - Dodge Diesel - Diesel Truck Resource Forums


3rd Gen Engine and Drivetrain -> 2003-2007 5.9 liter Engine and drivetrain discussion only. PLEASE, NO HIGH PERFORMANCE DISCUSSION!

Couple new noises after front u-joints and clutch install

Reply
 
 
 
Thread Tools Search this Thread
Old 01-31-2018, 07:42 AM   #1  
Registered User
Thread Starter
 
Join Date: Jul 2008
Location: MD
Posts: 49
Couple new noises after front u-joints and clutch install

2003 Dodge Ram 2500 HO 'C-code' Cummings. NV5600. Magnaflow exhaust, otherwise bone stock.

So around Christmas I changed the oil and found a front u joint was shot. So I pulled the hubs and axles and had the new joints pressed in at a shop. Now this was first time for me doing this on this truck. But after ending up with more issues the last time I farmed the job I figured I'd try it. Now my worry is the axles seals and if I get the axles back in without messing them up. Fingers crossed. Shortly after I had a SBB 1947OKHD installed.

Recently got the truck back and I'm getting used to the new parts. Have 2 questions because there have been a couple new things pop up, but they to date have only happened twice and there's not been a pattern to what caused it.

So i'll apologize now for the lack of info. this literally just started and I wanted to get it in now in case it gets worse, or in the off chance someone else had similar and could help catch something early.

1. Twice now while driving there has been sort of a screeching metal sound. Best I can describe it is like two pieces of metal rub together. No pattern to what causes it and I've not been able to duplicate. Seems like both times I was on a road with a slow sweeping left (different roads and places) and was doing between 45 and 55 MPH. This is like split second noise and then its gone. This morning when it happened I almost thought there was a 'grab' in the wheel and truck but the roads I was on is potholed up so I can't say if the 2 are related or not. last night when it happened the first time I parked it and went under looking for a loose cross member or something. If its that, me hanging on it and pulling back and forth didn't' make it show.

2. Still getting used to the new hydraulics (SBB 750 kit) and over all clutch feel. I almost feel like I'm pushing the petal too far when stopping. Basically pushing to the floor coming to a stop. Is there a bump stop or something for these so I don't push the pedal too far and mess up the hydraulics? If thats even possible. But I came to a stop after 60 mile drive this morning and pushed clutch in. there was slight vibration in the pedal and I noticed the RPM was up around 1000. Felt like the clutch was rubbing. Quickly, in Neutral let pedal up and reapplied, noise/grab feeling was gone and RPM as at 750 like normal.

Otherwise the truck is driving fine and I've not had any issues. Was curious what opinions are, if any can be made with these great descriptions . Thanks
Diesbull is offline   Reply With Quote
Old 02-01-2018, 05:03 AM   #2  
Registered User
Thread Starter
 
Join Date: Jul 2008
Location: MD
Posts: 49
Well Maybe it was nothing. I adjusted the pedal height yesterday on the way home, guess mechanic pulled them up. I dont' feel like I'm pushing the pedal too far any longer. And neither noise/issue has returned yet.
Diesbull is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
help diagnose a couple noises Beast2B 24 Valve Engine and Drivetrain 6 04-06-2010 08:25 PM
Strange noises since clutch replacement OutHuntin' 3rd Gen High Performance and Accessories (5.9L Only) 8 01-17-2008 02:39 PM
Weird noises after turbo rebuild. nateman Performance and Accessories 2nd gen only 0 03-12-2007 10:59 AM
Front end/Transfer case making some scary noises and vibrations NoSparkplugs 1st Gen. Ram - All Topics 9 12-07-2006 09:57 PM
2 kinds of clutch noises?? dodgediesel4x4 24 Valve Engine and Drivetrain 1 01-20-2004 12:58 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -5. The time now is 10:37 PM.


© 2018 MH Sub I, LLC dba Internet Brands
We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.