No bus on the odometer 99 3500 dually - Dodge Diesel - Diesel Truck Resource Forums

Notices
24 Valve Engine and Drivetrain Discuss the 24 Valve engine and drivetrain here. No non-drivetrain discussions please. NO HIGH PERFORMANCE DISCUSSION!

No bus on the odometer 99 3500 dually

Reply

 
 
 
Old 02-27-2018, 07:39 AM
  #1  
Registered User
Thread Starter
 
Join Date: Apr 2004
Location: St.Paul , MN
Posts: 731
Thanks: 0
Thanked 0 Times in 0 Posts
No bus on the odometer 99 3500 dually

Help! I need to move this truck quickly so the lot can be plowed. We have a ton of snow.
I started it ok but there is a “ no bus” on the odometer. It idles ok and the lights work.
But no throttle, just dead.

What’s this mean?

It’s a manual so I can maybe carefully back it out and idle it around. There is a slight hill so getting back up will be slow if at all.
bentwings is offline  
Reply With Quote
Old 02-27-2018, 04:49 PM
  #2  
Registered User
 
johnh's Avatar
 
Join Date: Nov 2002
Location: lyman, utah
Posts: 4,003
Thanks: 0
Thanked 23 Times in 22 Posts
Originally Posted by bentwings View Post
Help! I need to move this truck quickly so the lot can be plowed. We have a ton of snow.
I started it ok but there is a “ no bus” on the odometer. It idles ok and the lights work.
But no throttle, just dead.

What’s this mean?

It’s a manual so I can maybe carefully back it out and idle it around. There is a slight hill so getting back up will be slow if at all.
are there any codes?sounds like the TPS.... to get the codes, cycle the key switch 3 times but don't start it the 3d=rd time leave it in the on position and read the codes ...if it reads p0122, the Throttle Position Sensor need attention
johnh is offline  
Reply With Quote
Old 02-27-2018, 05:11 PM
  #3  
Registered User
Thread Starter
 
Join Date: Apr 2004
Location: St.Paul , MN
Posts: 731
Thanks: 0
Thanked 0 Times in 0 Posts
Thanks John,
Unfortunately on the 1999 model year you can’t do the key on key off thing. I think that started on the 2000 models.

I started the truck again and the “no bus” was off and the gages worked. I simply had to get the truck moved so I just idled it out of the parking spot and parked in the street while they were plowing.

I called a repair shop I use and he said they could clean and check electrical connections as the under hood is a mess due to PS leakage and all the snow we have had. It’s not rusty however. LOL One of the mechanics has a 99 3/4 ton Dodge Cummins with a 5 speed like mine.

I can’t do much out in the parking lot so he said to bring it in and he would go over it before we start replacing stuff. He says there are several fuses that often give this problem but not to rule out parts replacement like the TPS. He told me not to clear codes so he could look at them.

At least it runs and has good lift pump pressure. Probably can’t rule out the VP 44 however. It’s got over 250 k on it.

So I got AAA to haul the truck out to his shop as I had some other work I wanted him to do anyway.

I’ll post up the results as soon as I get the truck back.

Byron
bentwings is offline  
Reply With Quote
 
 
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
NE frmhnd
24 Valve Engine and Drivetrain
5
11-07-2012 10:13 PM
Michigan Ram
HELP!
11
07-02-2010 02:32 PM
ilw_01dodge
HELP!
16
02-20-2007 12:11 AM
RobG
HELP!
6
12-16-2005 09:56 PM
doug
Performance and Accessories 2nd gen only
1
06-05-2003 04:53 PM


Thread Tools
Search this Thread
Quick Reply: No bus on the odometer 99 3500 dually


Contact Us Archive Advertising Cookie Policy Privacy Statement Terms of Service

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.