Help with Throttle/Pedal Position Sensor - Dodge Diesel - Diesel Truck Resource Forums

24 Valve Engine and Drivetrain Discuss the 24 Valve engine and drivetrain here. No non-drivetrain discussions please. NO HIGH PERFORMANCE DISCUSSION!

Help with Throttle/Pedal Position Sensor

Reply

 
 
 
Old 01-26-2018, 06:15 PM
  #1  
Registered User
Thread Starter
 
Rufus's Avatar
 
Join Date: Feb 2010
Location: Garland Texas
Posts: 19
Thanks: 0
Thanked 0 Times in 0 Posts
Help with Throttle/Pedal Position Sensor

Hi Guys,
I had to replace the intake heater relay on my 01 2500 Diesel (24 valve) the other day, and when we cleared the code, another pulled up. This time it's the Throttle/Pedal Position Sensor/Switch B Circuit Low Input. The code reads out,PO222 but I found that it is really PO2122. Reading the threads on this subject, I see it's an APPS rather than aTPPS.
How do I determine if it is the sensor, or the connection?
Could I have fouled the connection while I was rooting around with the intake relay?
BTW, the truck seems to be running just fine, but the engine light is still on.
Any information you all can give will be appreciated.
Thanks
Have fun
Rufus
Rufus is offline  
Reply With Quote
Old 01-27-2018, 09:19 AM
  #2  
Registered User
 
Dieselbuilder's Avatar
 
Join Date: Mar 2002
Location: Nanoose Bay B.C. Canada
Posts: 745
Thanks: 0
Thanked 6 Times in 6 Posts
We have a APPS not a TPPS
Dieselbuilder is offline  
Reply With Quote
Old 01-27-2018, 06:10 PM
  #3  
Registered User
 
Join Date: Aug 2007
Location: Edmonton, Alberta
Posts: 3,893
Thanked 29 Times in 27 Posts
Originally Posted by Rufus View Post
Hi Guys,
I had to replace the intake heater relay on my 01 2500 Diesel (24 valve) the other day, and when we cleared the code, another pulled up. This time it's the Throttle/Pedal Position Sensor/Switch B Circuit Low Input. The code reads out,PO222 but I found that it is really PO2122. Reading the threads on this subject, I see it's an APPS rather than aTPPS.
How do I determine if it is the sensor, or the connection?
Could I have fouled the connection while I was rooting around with the intake relay?
BTW, the truck seems to be running just fine, but the engine light is still on.
Any information you all can give will be appreciated.
Thanks
Have fun
Rufus
Quick, order your Timbo APPS now and keep it until you need it or just change it out now, it will save you a bundle of money and a lot of hassle.
Busboy is offline  
Reply With Quote
Old 01-28-2018, 11:18 AM
  #4  
Registered User
 
SIXSLUG's Avatar
 
Join Date: May 2006
Location: Pacific NW, B'ham, Kalispell MT
Posts: 5,068
Thanks: 0
Thanked 35 Times in 31 Posts
On an 01 with 115K you are probably due for a new APPS. I put a timbo on mine back then and its a non issue.

I didn't have a code, just an odd miss at any steady speed....
SIXSLUG is offline  
Reply With Quote
 
 
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
jeramy125
3rd Gen Engine and Drivetrain -> 2003-2007
3
07-01-2009 08:46 AM
cwg
3rd Gen Engine and Drivetrain -> 2003-2007
2
04-14-2009 07:38 PM
swktk1
HELP!
3
06-26-2005 09:23 PM
tishmael
HELP!
22
08-31-2003 11:49 PM
tishmael
24 Valve Engine and Drivetrain
13
12-02-2002 12:39 PM


Thread Tools
Search this Thread
Quick Reply: Help with Throttle/Pedal Position Sensor


Contact Us Archive Advertising Cookie Policy Privacy Statement Terms of Service

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.