Go Back   Dodge Diesel - Diesel Truck Resource Forums > 3rd Generation Ram - Years 2003 and up > 3rd Gen Engine and Drivetrain -> 2003-2007
Sign in using an external account
Register Forgot Password?
Search

Reply

 
 
 
submit to reddit
 
Thread Tools Search this Thread Display Modes
Old 03-14-2012, 04:38 PM   #1
C Pierce
Registered User
 
C Pierce's Avatar
 
Join Date: Jan 2005
Location: Plant City FL
Posts: 236
error codes?

I just bought an 03 HO 3500 (haven't changed my Sig yet) and its throwing these codes.
P0602-ECM FUELING CALIBRATION ERROR

P0580-LOW VOLTAGE DETECTED AT THE SPEED CONTROL MULTIPLEXED SWITCH
Which is probably why my cruise isn't working


P0234-TURBOCHARGER OVERBOOST CONDITION

How do I go about fixing these problems? I see velcro strips on the fuse box so someone had a programmer on it at one time.
Can I reset it or do need to have dodge look at it? Sorry for the noob questions I've only owned a first gen up till now.
__________________
2003 4x4 3500 QC HO
C Pierce is offline   Reply With Quote
Old 03-15-2012, 02:31 PM   #2
luke03cr
Registered User
 
luke03cr's Avatar
 
Join Date: Jun 2011
Location: clinton, tn
Posts: 84
Clear the codes with a SCAN TOOL, drive truck until they come back on..if they do. Then go from there with diag.
__________________
2003 CTD, srw 3500, 4x4 auto, 4dr, 4in exhaust, bully dog triple dog, levelin kit wit 35's, painted to match fender flares, 270k
luke03cr is offline   Reply With Quote
Old 03-15-2012, 10:47 PM   #3
C Pierce
Registered User
 
C Pierce's Avatar
 
Join Date: Jan 2005
Location: Plant City FL
Posts: 236
Thanks I went to Advance Auto today and had them cleared but their scan too only brought up one of the codes twice (over boost condition) the low voltage to throttle control code also went away but the 0602 (fuel calibration error) never went away and by this evening they were all back. The truck seems to be running fine, it will pull past 2700 with no hesitation but I've never driven a 2nd or 3rd gen before now so i'm not familiar with exactly how it should run or how strongly it should accelerate. Thanks for the reply and sorry if the questions seem dumb, I'm just still trying to get my bearings straight with the 3rd gen.

Clint
C Pierce is offline   Reply With Quote
Old 03-15-2012, 10:47 PM
 
 
 
submit to reddit
Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 12:21 PM.


Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
vB.Sponsors
Copyright 2011, DieselTruckResource.Com
Contacts Backup