PDA

View Full Version : rancho shock makin noiose


j
11-07-2002, 11:29 PM
we just had our first rain today which i think made the noise more noticable, but there seems to be a clunking noise coming from the front outsides and the rear outsides when i go over a bump. it didnt do this with the stock shocks and i noticed a little noise from the rancho's when i put them in, but thought nothing of it. now it seems real bad. any thoughts?

RATTLINRAM
11-08-2002, 02:49 AM
I used our search fuction and typed in &quot;shock noise&quot; and this was just one of the threads concerning a problem like yours.<br>LOOK HERE (http://www.dodge-diesel.org/yabbse/index.php?board=5;action=display;threadid=1006;sta rt=0)<br> Hope this helps.

bkay
11-08-2002, 09:21 AM
Just replaced my Ranchos last night. The bottom gromments were wore slap out. I did notice that the new ones are built differently. Stud threads are different as well as the bottom grommets.

j
11-08-2002, 07:24 PM
luckily i had training this week so i have the next 5 days off. i'll be sure to check the bolts and try to figure out what the noise is from. thanks RATTLIN for the previous posts...<br>

Alan_Reagan
11-09-2002, 04:06 PM
J., When I installed Ranchos on my 98 I found the top mount on the Ranchos was a little smaller than the OEM shocks. Therefore, the grommet has to be alligned perfectly and has to be very tight or it will bump or knock. Tighten up the top mounts.

Big dawg
11-10-2002, 10:20 AM
J.,<br> Your not alone on this problem :'( I put on the R9000X last week and I noticed a thumping coming from the front passenger side :o Thought it was just me for the first 50 miles or so. I just retighten the front top bolts in the hopes it helps the problem. Anybody else have a cure for this thumping problem other than going back to the stock shocks??? <br> Big dawg

Dieselbuilder
11-10-2002, 10:40 AM
One thing to check, that I had found replaceing the shocks on my 98 the stock bolts were smaller in diameter than the eyes of the shock. Went down to the hardwhare store bought new ones the right size, front and rear prolbem solved.