PDA

View Full Version : 5000 miles later and... it's dead.


m8powr
04-23-2011, 11:22 AM
Driving down the highway yesterday and every warning light on the dash came on, then it just shut off. Pulled over. Won't start - wont do anything besides flash "Service Park Sensors, Service Trailer System, Service Transmission, Service Electronic Throttle, Low Tire Pressure, etc." It's at the dealer now. Anyone have a similar issue? I'm thinking ECU fried or something. No mods (thank god I didn't do tuner yet). Was really fun getting honked by the Fords and Chevys cruising by, still running. Thought it was supposed to be the opposite! [dummy]

On another note - dealer (Carl Burger) wouldn't offer me a loaner or a shuttle to get back where I needed to go. Really upset.

RAMRODD
04-23-2011, 10:08 PM
Thats sucks man but if it makes you feel better, I stopped to see if I could help out a stranded durmax today. He said the truck just died he was pulling a enclosed snowmobile trailer. Truck was a 2011

arcojet
04-23-2011, 11:44 PM
Ya, mine did that once. I tried everything to get it started but no go. Then I thought about just unhooking the batteries to see if it would reset things. It worked and now I keep my little socket wrench handy just in case.

What a pain in the arse for a new truck[tapdshut][verymad]

m8powr
04-26-2011, 04:24 PM
Apparently PCM shorted out in three different places (randomly)... Fixed and picking up today/tomorrow. VERY happy this didn't happen in middle of nowhere :( also praying it doesn't happen again or she might be a lemon law!

m8powr
04-26-2011, 04:29 PM
P.S. - Dodge corporate was nice and offered to pay for a rental truck so at least they are somewhat service oriented.

cbrahs
04-26-2011, 04:52 PM
dodge does not pay for rental unless you either purchase rental contract OR are set up with business link.

BUT the dealer has the choice of providing a "loaner" if they are set up thru their insurance company to do so.

For Chrysler to step up and pay is few and far between. Glad to see they did but I would bet money that the dealer is eating the rental truck. they are looking for that 100% satisfied on a survey. wager a cup of coffee that you get a talking to about the survey before you get your truck back! :) lol

yellowhemi
04-26-2011, 05:19 PM
I am a business link member and have always been taken care of.

m8powr
04-28-2011, 05:47 PM
Well... after another trip to dealer bc of check engine light (they "forgot" to program coded injectors) - truck is back and running. Everything seems OK except they lightly scratched my fender leaning on it and delivered the truck back filthy.

The loaner was authorized through Dodge corporate and they were going to reimburse me. I didn't end up getting it as I didn't need the truck until today.

and cbrahs - you owe me a cup of coffee! no survey info. and they won't get a good rating from me if i get surveyed.

cbrahs
04-28-2011, 06:12 PM
strange. forgot to program coded injectors huh? truck won't even run at all if they are not programmed into the ecm.

keep a tab. next time you are thru albquerque or I am thru there. its on! lol

Grand Geek
04-29-2011, 01:41 AM
Everything seems OK except they lightly scratched my fender leaning on it and delivered the truck back filthy.


[nonono] Thats crap that you get that kinda service. Dodge (Capitol) did that to my wives grand when it was in for a oil change. I had fun sitting in the passanger side when she ripped them a new one and they paid for a major detailing at a shop that they have no control over.

redlineguy
04-29-2011, 08:25 AM
[nonono] Thats crap that you get that kinda service. Dodge (Capitol) did that to my wives grand when it was in for a oil change. I had fun sitting in the passanger side when she ripped them a new one and they paid for a major detailing at a shop that they have no control over.





Cuz for ones it was not you getting a new one ripped?? LOL;)